M-100 Message Board
M-100 Message Board
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 M-100 Message Forum
 Fuel Management
 600 injection pump
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

0405

14 Posts

Posted - 08/26/2016 :  03:45:46  Show Profile  Reply with Quote
Started our low kilometre 600 after 15 years and after beating feeder pump. engine fired and went to full revs.
unfortunately didn't check cold start solenoid on pump for jamming,and removed one inlet manifold and pump side cover to see if rack was jammed on.I have cover off side of pump where you can only see fuel cylinders[elements?]with small gears that run against fuel rack.The cylinders turn to left and right with heavy finger pressure but don't return to original position.I thought spring or governor pressure held rack at idle position?Removed cold start solenoid seems OK,but shaft in middle of solenoid has no spring pressure on it.I thought all solenoids had spring pressure on way and electrical current pulled a shaft against the spring? Pump is common Bosch 9UG98002XK87,fitted to 6 and 8 cylinder Mercedes.Anyone have any clues?Any input would really be appreciated?Regards Keith.
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
M-100 Message Board © 2002-2015 International M-100 Group, Inc. Go To Top Of Page
This page was generated in 0.36 seconds. Powered By: Snitz Forums 2000 Version 3.4.06